Weathered AHM E-L SW-1 - Page 2 - Model Train Forum - the complete model train resource
Model Train Forum - the complete model train resource

Go Back   Model Train Forum - the complete model train resource > Model Train Multimedia > Model Train Photo Gallery
Forgotten your password?

Model Train Photo Gallery Post model train pics in here.


Reply
 
Thread Tools Display Modes
Old 06-17-2017, 04:22 PM   #11
LostInHoboken
Hobo
 
LostInHoboken's Avatar
 
Join Date: Jun 2017
Location: New England
Posts: 29
Scales Modeled: HO
Quote:
Originally Posted by time warp View Post
This is an earlier version of the same engine that doesn't have the notch. I found this one NIB at The Roundhouse in Louisville, KY. It was made new in '74.
Oh, I see. Still a beautiful machine. I'm resigned to that giant gap, because if I ever want to take the thing apart someday...
LostInHoboken is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-17-2017, 05:37 PM   #12
time warp
Station Master
 
time warp's Avatar
 
Join Date: Apr 2016
Location: Brazil, Indiana. 10 klicks from the Chinook mine
Posts: 2,715
Scales Modeled: Old School HO and British OO
Yours is in nice shape, a lot of them have the railings all busted up and missing the bell. Here is the dummy unit I powered with stock parts, it wasn't hard and made a nice engine. This one is the later version and has the notch like the one you have. We need to make yours run!

0617171829.jpg
time warp is offline   Reply With Quote
Old 06-19-2017, 02:34 PM   #13
LostInHoboken
Hobo
 
LostInHoboken's Avatar
 
Join Date: Jun 2017
Location: New England
Posts: 29
Scales Modeled: HO
Quote:
Originally Posted by time warp View Post
Yours is in nice shape, a lot of them have the railings all busted up and missing the bell. Here is the dummy unit I powered with stock parts, it wasn't hard and made a nice engine. This one is the later version and has the notch like the one you have. We need to make yours run!

Attachment 318626
Your Rock Island switcher is very pretty. Actually I have two of these units - one dummy and one sort of powered - both of which I (over) weathered. The powered one, a buy off eBay, runs when it feels like it, which is about the same as its owner. The dummy unit must have been run to death, because the wheels in the trucks are super wobbly, and I don't feel confident in trying to break open the things to see if they are fixable. So the dummy is just a prop for the yard.

Just finished a Pola freight shed to add to the layout. Will try to get pix up soon.
LostInHoboken is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Visit These Sites:
LGB World

Or Our European Train Website ModelRailForum




All times are GMT -5. The time now is 05:37 AM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.