Suggestions Please - Model Train Forum - the complete model train resource
Model Train Forum - the complete model train resource

Go Back   Model Train Forum - the complete model train resource > Scale Specific Model Train Forum > OO Scale
Forgotten your password?

OO Scale Airfix, Bachmann Branchline, Peco, Dapol, Lima, Kitmaster and all other OO scale discussions here.


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-19-2019, 12:49 PM   #1
MrStucky
Brakeman
 
Join Date: Nov 2015
Location: Edmonton
Posts: 187
Suggestions Please

Hello everyone.
I have a OO train set received as a gift from 1980. Iím in the process of cleaning & lubricating. I watched a how to video on YouTube the other day, then got to work on my own train. I noticed the cover of the ring field motor isnít properly attached as a clip on the right hand side has broken off. Iím still having issues with some of my engines on my layout, so I figured Iíd check the trains first. Iím thinking of using foam tape at the top of the motor, to keep everything together. The motor still runs after all these years.
Thanks
Attached Images
File Type: jpg 83245A34-BDAA-40A3-8584-39AA0D7BDC1B.jpg (107.7 KB, 10 views)
File Type: jpg 40F746D9-0084-4695-9086-078B15D58012.jpg (122.4 KB, 10 views)
MrStucky is offline   Reply With Quote
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Visit These Sites:
LGB World

Or Our European Train Website ModelRailForum




All times are GMT -5. The time now is 04:33 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.