Model Train Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
First time fooling around eith trains in 20 years. I bought bachman silver streak set on E Bay, set up 56X36 oval, and I'm super dissapointed. Incredibly difficult setting cars on track (steel easy track) and once I get them all on one or more cars derail after one or two laps. Also set came with 2 locomotives, one doesn't work at all and the other runs sporatically,. I have to constantly nudge it around track or it just stops cold. Is this typical of this caliber set or did I ripped off? thanks for any help.
 

·
Registered
Joined
·
2,617 Posts
Welcome to the forum, but sorry to hear of your troubles...

Is this what you bought?

http://www.trainsetsonly.com/page/TSO/PROD/160-627

A set like this includes one powered engine and one "dummy" engine... The "dummy" engine looks like a real working engine, but it actually has no internals to it...

As far as the other one which you need to nudge, try cleaing the track... Sandpaper works, or you can buy some special cleaning solution... Something else which will help is to oil/grease the mechanics of the engine, especially if it has been sitting for a while...

Now I have had no experience with HO, so I do not know why your cars are derailing... Obviously make sure the track is connected tightly... Normally with my O trains the engine derails before anything else, but I have since learned no to go full speed around the corners :rolleyes:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the info. I've since completely dismantled the oval and reconnected very carefully. I've already learned that the easy track still requires some patience and care when asembling, o you end up with ever so slight imperfections where rails meet. Set is running much smoother now. I didn't know about dummie engine, but that explains it. It fooled me being the same weight and all. I'm still finding it a little difficult setting cars on the rails correctly, but once there all down, everything runs okay.
 

·
Registered
Joined
·
4 Posts
Sorry to hear of your trouble

I would reccommend switching to Kato track. I may get flamed for this but I have found that the Bachmann track in these sets can be troublesome. I have several Bachmann and Athearn setups that came with Bachmann track and the first thing I did was to ditch the track and switch to kato. Problems seem to vaporize. Just mho.

The Rix Products HO Scale Rail-It, that was suggested by Shaygetz is a great device for those of that have vision and back problems. I highly reccommend it also.
 
1 - 6 of 6 Posts
Top