Model Train Forum banner

1 - 20 of 107 Posts

·
Registered
Joined
·
2,617 Posts
Discussion Starter #1 (Edited)
Method 1: Attachment

The simplest way to post an image (this works with other files too) on the forum is to attach it to your post... To do this, scroll down a bit when posting and select "Manage Attachments" under the Additional Options section...



When you do, a new window will open... Click on one of the "Browse" buttons, locate and select the file you want to upload from your computer, and click on the "Open" button... Repeat this process until you have selected all of the files that you want to attach, and then click on the "Upload" button...



Once it shows that they have all uploaded, close the window... When you submit your post, links to the images will automatically appear after all of your text, just like the example in this post...

If you want to delete any attachments in the future, first go to your User CP (the link is in the horizontal menu near the top of forum pages)... Once there, look for the Miscellaneous category in the side menu and click on the "Attachments" button... To delete an image, simply click on its check-box and then on the "Delete Selected" button...

...
 

Attachments

·
Registered
Joined
·
2,617 Posts
Discussion Starter #2 (Edited)
Method 2: The Gallery

Another way to post images is to use the Gallery here at the MTF... To access the Gallery, click on "Gallery" in the horizontal menu near the top of any forum page, and then to upload images, click on the "Upload" button in the horizontal Gallery menu...



After the page loads, click on one of the "Browse" buttons, locate and select the file you want to upload from your computer, and click on the "Open" button... Repeat this process until you have selected all of the files that you want to upload... The next step is to insert an image title... If you leave the field blank, the file name will automatically be used for the image name... You also need to select which sub-gallery that you want to upload your pictures to... The "Member Galleries" option will place the images in your own personal album, but the other three main options will place your images amongst fellow forum member's images... There are also the options to insert a description and some keywords if you so desire... Once you are finished, click on the "Submit" button to move to the final step...



If you are uploading multiple images (this step is not necessary if you are only uploading one and will be automatically skipped), you can give them unique names, locations, descriptions, and keywords in this step... After you are done, click on the "Process" button to finish uploading the images... On a side note, the maximum width for a Gallery image is 800px and the maximum height is 600px... If any of your pictures are bigger than these dimensions, they will automatically be scaled down to meet the size limits...



Now, to locate the new images, click on the "My Stuff" drop-down menu in the horizontal Gallery menu and then select "My Images"... If you want to insert the pictures into a post you will need a specific link... Click on the thumbnail of the image you want to post, and then copy (Ctrl + C) the "Direct Link Code" URL from the image's page...



When making your post, click on the image of the mountain... If the pop-up is blocked, allow it... In the small window that opens, paste (Ctrl + V) the URL into the text box, making sure that you do not end up with http://http:// as that will mess up your link...



After you click the "Okay" button, the window will close and you will see the URL in IMG tags... Repeat this process until you have all of the images inserted into the Message box... Make sure that you hit enter after every ending IMG tag, otherwise you will stretch the thread... If you would prefer, you can also just paste the URL into the Message box and add IMG tags around it, rather than having to click on the Insert Image button every time...



------------------------------

Method 3: 3rd Party Site

The third way to post pictures on the forum is to host them on a third party website, such as Photobucket... If you choose this option, you will need to create an account on Photobucket if you do not already have one...

Before you start to upload images from your computer to Photobucket, click on the "More Options" button under the big blue "Upload" button... To have the images work best with the forum, make sure that one of the size options circled below is selected...





Now, click on the big "Upload" button to start uploading images from your computer... Locate and select the files you want to upload from your computer, and click on the "Open" button... You can hold down the Ctrl key to select multiple files at the same time to speed up the process... The images will upload automatically and you will be taken to a page where you can enter titles, descriptions, and tags for your pictures...



If you choose the "Save and Return to Album" option, you will need to locate the image you want to post here at the MTF, hover your pointer over it, and then copy the "IMG Code" from the drop-down that appears...



If you choose the "Save and Get Links" option, you just need to highlight and copy the "IMG Code"... The "Share Everything" link at the top of the page will link to the album where your pictures are located, and not individual images...



To insert the image into your post, simply paste the "IMG Code" into the Message box... Again, make sure that you hit enter after every ending IMG tag, otherwise you will stretch the thread...

 

·
Moderator
Joined
·
16,666 Posts
Having trouble with Upload of photos to Gallery

Hi all,

Help! I'm new to the forum, and thought I'd upload about 10 pics of my new HO layout to the gallery. I navigated to Gallery / Upload, and then used Browse to select the filepaths of 10 images on my computer. I then entered some text for Image Title and Description, and toggled Member Layouts as my choice of Category. After doing the above, I clicked on Submit. My computer whirred away for a few seconds, and I could see that stuff was being sent out through my Ethernet cable. But, after a few seconds, I was popped back to a "virgin" Upload page, with no evidence that my photos were ever uploaded. I tried this 3 times with the same results.

My images are color jpg's, about 900 KB in size, though about 2300 x 1800 pixels. Is that too big? I thought if the file was under 2MB, it would be OK.

Any help / suggestions at all?

Much appreciated!

TJ
 

·
Registered
Joined
·
2,617 Posts
Discussion Starter #5
You are right in that the maximum file size is 2MB... Now, when you upload to the gallery, the maximum dimensions will be 800px by 600px... The forum will usually automatically resize any images that are slightly bigger, but yours may just be too big...

To shrink them yourself, you can use Picnik online or download GIMP to your computer... Let me know how it goes and if you have any further questions :)
 

·
Moderator
Joined
·
16,666 Posts
Hi Boston&Maine,

Thanks! I really appreciate your tip! That worked ... I downsized each of my 10 pics to 800x600, then ran through the Upload process without any problems.

I now see my pics under Gallery / Member Layouts. Great! However ...

If I look at the architecture of the Home Page, I would have thought that these now-uploaded pics would have been cross-referenced to the "My Layout" section under Model Train Workshop. Maybe not ...

Is "Member Layouts" different from "My Layouts" ?

TJ
 

·
Moderator
Joined
·
16,666 Posts
Thanks! Did it ... pics now under both "Gallery / Member Layouts" and "My Layouts". From my basement to the 'net!
 

·
Moderator
Joined
·
16,666 Posts
Hi B&M,

Another "posting pictures" question that has me baffled ...

On several posts, I've used Attachments to upload photos, and then these appear only as icons in the thread. Someone has to click on the icon to see my pics.

However, I've seen that posts from many other people have their actual pictures imbedded right in the thread itself. You see the picture as you're scrolling through the thread and text.

What gives? How do I do the latter? Is it dependent upon the type of image? I'm usually using jpg files. Is it dependent upon my (naive) settings choice of how I'm viewing threads?

Go easy on me here ... I'm an old dog, and these are all new tricks!
 

·
Moderator
Joined
·
16,666 Posts
Hi Tankist,

Thanks for your patience ... I think I've (finally) got it ... attach vs. insert (with required URL pointer). Let's give it a shot ...



If we see a happy face, I've learned a new trick today.

As an aside, it looks like images uploaded to the Gallery (and then later inserted) get downsized to 800x600, whereas attached images can be larger in pixels (a jpg capped at 1000x1000, for example).

Thanks VERY much for your help ... much appreciated!

TJ
 

·
Registered
Joined
·
2,951 Posts
it probably should go into this thread instead.

That didn't answer my queiry Anton, I already have pics in my folder but when I put the link into my post it only showed as a small red square.
probably because you attaching a picture file instead of inserting it into post. two different things

also what is 'my folder'? you mean your online Album (on this forum) or file folder on your PC?
 

·
Registered
Joined
·
60 Posts
it probably should go into this thread instead.


probably because you attaching a picture file instead of inserting it into post. two different things

also what is 'my folder'? you mean your online Album (on this forum) or file folder on your PC?
Sorry Anton, I'm not sure you understand what I'm saying here,

A.- I was not attaching a picture but inserting an image.
B.- yes my online album (on this forum)
C.- this is where chat comes into its own as we could have got to the bottom of this by now.

 

·
Registered
Joined
·
2,951 Posts
I put one into the post before this one in my answer to you.

http://www.modeltrainforum.com/galle...=3&userid=2534
this one
this is not URL of an image, this is URL of the gallery page containing the image. so, what is the URL of the image then ? ;)



when you take the proper URL and enclose it in IMG tags you get this (as described in method 2): you get the result below.

 

·
Registered
Joined
·
2,617 Posts
Discussion Starter #18
RadFan, you are using the wrong links in your IMG tags...

Now, to locate the new images, click on the "My Stuff" drop-down menu in the horizontal Gallery menu and then select "My Images"... If you want to insert the pictures into a post you will need a specific link... Click on the thumbnail of the image you want to post, and then copy (Ctrl + C) the "Direct Link Code" URL from the image's page...

 

·
Registered
Joined
·
60 Posts
Man thats a lot of pfaffing around, whats wrong with good old copy paste,lol

I dont think I have enough short term memory to remember all that without having to come back to this thread and read it all again
 

·
Registered
Joined
·
60 Posts
this is not URL of an image, this is URL of the gallery page containing the image. so, what is the URL of the image then ? ;)



when you take the proper URL and enclose it in IMG tags you get this (as described in method 2): you get the result below.

you lost me!
 
1 - 20 of 107 Posts
Top