Model Train Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,105 Posts
Discussion Starter #1
Greetings -
I am a NEW user of JMRI software. I learned about this software a couple of days ago and am very much interested is using it to program my engine decoders. I just finished installing it and attempted to use the Decoder Pro. I got the following error message:

“Wrong revision of Command Station EPRON selected in preferences - Change the Command Station EPRON selection to “2004 or earlier”

Spent about 45 minutes searching for a way to do this and have come up empty.

Background info: NCE Control System. Windows 10 OS, Latest version of JAVA and Latest version of JMRI. BOTH installed yesterday.

Thanks in advance for your help.
 

·
Registered
Joined
·
1,488 Posts
Seems like it could be the nce side. Is "epron" actually "eprom". It may be telling you to upgrade the nce controllers software (aka "firmware"). I don't have one of them (an nce) but that could make sense. Maybe the nce website has something about that?
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter #7
Thanks to everybody that responded. I was able to find the answer on the JMRI Users Group Forum.
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter #9
Solution:

1 - Start DecoderPro
2 - Go into EDIT > PREFERENCES
3 - Find the "Additional Connection Settings " tick the box.
4 - Find "Command Station EPROM "
5 - Open drop box and select "2004 or earlier."
6 - Save settings and re-start application.
 
1 - 9 of 9 Posts
Top