Model Train Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
936 Posts
Discussion Starter · #1 ·
I ordered the one that the MTH people said was the right battery. Got it yesterday and I'm not sure it is really the right battery. It is not the square one in this engine. The new one is blue and larger than the other one which is green. And being larger it doesn't fit in the battery holder in the engine. Is there yet a third battery option for MTH engines?
 

·
Registered
Joined
·
936 Posts
Discussion Starter · #3 ·
The only 2 that came up on MTH's site were those you just pictured. And I said above it isn't the square one :) I got the battery part number from them, the one they said was the right one and it is the blue one you pictured. But it is bigger than the one in the engine which is green and NOT square. It plugs in but can't fit in the battery holder in the engine. The green one sitting there was in the engine, the blue one is what they sent and that black metal piece behind those green tabs is what the battery is suppose to git into which the blue one cannot.
DSC_7834.jpg
 

·
Registered
Joined
·
936 Posts
Discussion Starter · #5 ·
Same thing as before... will start up but then shuts down when you try to go any directioin. The first two times I charged it up and it was ok for about a week and now that doesn't fix the problem. Of course, they *should* last longer, but as we all know with things, it isn't a given :) I gave them the model number when ordering and they said that was the right one, so I call them in a few min I guess
 

·
Registered
Joined
·
1,266 Posts
The capacitor battery eliminator is the way to go. They are pricey but the performance of MTH NI-cads is atrocious.
 

·
Registered
Joined
·
936 Posts
Discussion Starter · #9 ·
No way to fit the larger battery in? If not, you'll have to get the smaller package.
It won't fit in the battery holder in there and I couldn't force it to open to put it in there. It's plugged in and with the shell still off charging the battery. figured I would make sure that the battery is really the issue, but you had thought it was likely that as did the service people last week when I called and I read that as well online. I can probably tape the bigger battery to the holder and make this one work.
 

·
Registered
Joined
·
936 Posts
Discussion Starter · #12 ·
Ran the engine with the shell off and the new battery just sitting there and everything functioned properly so it was indeed the battery. Going to go ahead and let it charge up just to make sure it is fully charged.
 
1 - 15 of 15 Posts
Top