Model Train Forum banner
1 - 20 of 43 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Hi all. I tried to test this engine and it ran one time around the track, no headlights or ditch lights but there was a cabin light. I accidently hit the direction button on the transformer and now the engine won't move. It powers up and idles. Horn and bell work. But it will not move. I don't have a manual for it and I'm not that familiar with all the ins and outs of these. I have a standard AC layout.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
As it turns out I guess it was the battery. I put a 9v in it and was able to get it running. It had a nicad in it. I tried to recharge it but I think it's bad. The only thing is I have no lights other than the interior cabin lights. I guess I will need to figure out if I can get all the lights to work. Can anyone tell me what to look for first?
 

·
Admin
Joined
·
47,883 Posts
Well, you can start with a conventional reset,

If the engine starts moving after startup or a few seconds after power applied that usually is a locked engine. For PS-3 I leave the voltage low at 8-9V until engine sounds fully start up, than I do a Reset 1W and 5B or an Unlock 1W and 3B. For PS-2 the engine normally has to be in neutral to do a reset, so I do an unlock (this also applies to Loco Sound engines).
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #9 ·
I wonder if doing a reset as the manual says would help any. Like I said, I'm new to this and I just run a conventional layout. The engine runs great. Bell and horn work. Startup, idle, and shut down all work. Just no outside lighting.
 

·
Registered
Joined
·
5,632 Posts
Well, you could run it without lights. Or you could check to make sure the plugs are tight. Or you could replace the lights. I suspect those are incandescent lights and they may have burned out after 18 years of operation.
 

·
Registered
Joined
·
5,632 Posts
The MTH parts site comes up empty for your model.

MTH Electric Trains (mthpartsandsales.com)

The premier diesel parts manual that MTH put out in 2015 has earlier models then yours, but what is interesting is that it shows the lights mounted to the shell and the electrical connection by spring contacts (PN 27 &30). The operator’s manual on beachead2's post shows the light mounted to a bracket which is mounted to the frame. But then MTH isn’t always up to date with their manuals.

Which arrangement does you model have? If it has spring contacts, they may be loose/not making good contact.

If you need parts, you could try to contact MTH via the site I linked.

Edit: Actually, the MTH parts site does come up with a generic PS2, 5V electronics parts breakdown which includes lights, but I would contact MTH to make sure that is correct for your model.
 

·
Admin
Joined
·
47,883 Posts
I'd be looking at wiring first. The bulbs are actually driven using PWM from the PV unregulated voltage. I believe they actually read the voltage and adjust the PWM duty cycle to maintain the constant intensity. I wonder if the PV wire that supplies the hot side of all the lights may be broken.
 
1 - 20 of 43 Posts
Top