Model Train Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
First, Hello, I am new to the forum and excited to get back into HO railroading. I started as a child and most of my stuff has been in boxes for the last 20 years.

I picked up a free layout off of craigslist.org the other day. It is from the 70's and works ok. I am having some issues with the switches and needs some help. The swiches are clicking back and forth but are not switching the tracks. The track parts stick due to friction and oldness. Would graphite be the best solution? Also, I am having connection issues with a few of the switches. The switch track is O'so close to the main live track line but not enought to keep a good connection. I have added a link to some pictures if that helps. Any suggestions?

Link to pics
 

·
Schizophrenic Engineer
Joined
·
3,076 Posts
Will the track switch by hand with the switch?

For freeing up old stuck stuff I like "PB Blaster". Spary in a contaner then use a tooth pick to put it where needed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I can push the switch lever back and forth and I can manually push the rails over. But the switch does not have enough in them to move the rails.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I went through and cleaned up the contacts and most of the switches are working now. I still have 3 that stick and have bad connections. I also found that one of my 2-way switches was all melted inside.
 
1 - 6 of 6 Posts
Top