Model Train Forum banner

Programming Track Setup Issues

1318 Views 14 Replies 6 Participants Last post by  JDTractorGuy

I've been trying to get back into the model railroad hobby after a long hiatus, and am discovering a lot of cool features that I'd like to use. I had a Digitrax DCS 50 as a kid and had no idea that it could program the decoders and am trying to set up a programming track. However, I keep getting a D nD error whenever I try and read or write a decoder address. I've tried with two different locomotives (One Athearn, no sound, and one Broadway Limited Imports, with sound) and both give the same error. A digitrax website said to put a resistor in the Prog A and Prog B outputs, and when I tried that, the Broadway limiteds sound and lights cut on when I attempted to write the decoder address. I'm sure that I've got my wires hooked up right. I read a constant ~1.5 volts on the programming track.

What am I doing wrong?

Thanks in advance!
1 - 7 of 15 Posts
Thanks for the replies.

ncrc: my concern is that buying that won't fix my problem, because I can't get it to work with either of my DCC locomotives. My athern genesis diesel gives a d nd error as well.

mesenteria: I think you've misunderstood my problem. I can run the trains fine. One of them was already set to the address I want, the other is set to 03. I'm trying to change it to a different address but the control system doesn't detect the engine when I put it on the programming track, and it won't even detect the engine that has the right address either. I haven't even gotten to the Yes/No step because it gives me an error. I'm using the digitrax manual that came with the DCS 50.
Thanks again for the help.

In regards to distance, its about 6 inches away from the unit on a single piece of straight track connected to the unit with 14 gauge wire.

The LED will light up and it pops up PAGE on the display--I can hit program again and it will then go to direct mode. I have tried setting the address using both modes but it still gives me a d nd error.

Thank you all again!
Yes, I tried reading them as well--still just a d nd error.

Do you mean 14 volts on the main track or the programming track? I show 17 on the main track when I send it power and ~1.5 on the programming track when I put it in programming mode.

I did win an auction for a power booster on eBay, so I'll see if that helps, and then if not call them up.
Right so still having issues. Got the booster in from the eBay auction and it works. However, I still can't read or write the address on any locomotive. I also got a new Digitrax decoder in and wired it up. Its running address 03 but won't read either. I've tried switching programming tracks as well--no dice. With the new booster, when I try and read or write the address the light in the engine comes on and I can hear the motor trying to turn a bit, so its obviously getting the signal. Any other ideas?
I plan to on Monday, but even if I have a bad unit I doubt there's anything they can do--its over 15 years old...
1 - 7 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.