Model Train Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm having trouble finding a transformer that works with the RailKing Denver Rio Grande. The manual lists some really old transformers that I don't want to try because I can't send them back if they don't work. I tried 2 different Lionel transformers and 2 different tracks with no success. Has anyone had any luck with a newer transformer? The lights turn on when it's on the track but the engine wont start up. Thanks.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
The model is 30-2184-1 F-3 AA Diesel Set. I tried the CW80 transformer and an older one that came with a different set that says #4060 Lionel. This is the first train I haven't been able to get running. The wheels are also locked but I've read that is normal for this train and I need to find the correct transformer to get it to run before the wheels will move. Thanks.
 

·
Admin
Joined
·
44,009 Posts
Well, the #4060 is certainly compatible, so assuming the transformer was functional, I suspect the issue is the engine. This is a 20 year old engine, so the first thing you should do is replace the battery, as the old battery is surely dead. With Protosound, that will keep it from moving, though you should get sounds. You can't turn the wheels by hand, only by taking the shell off and rotating the motors can you move the wheels by hand.

This is the 30-2184-1 F-3 A-A User's Manual, it mentions the 5 year life of the battery that's now 20 years old. ;) Later in the manual, they illustrate the four body mount screws you'll need to remove to change the battery. Any quality 7 cell NiMh 9V battery is good, I use the EBL brand.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Great. The transformer is definitely functional so it must be the battery. Thank you so much for the help!!!!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I opened it up, took out the battery and ordered a new one on Amazon. Thanks again for the help.
 
1 - 7 of 7 Posts
Top