Model Train Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter #1
Ok, I have picked up a brand NIB still had the plastic wrap on it, Bachmann Spectrum steam engine off ebay. The engine came in, still in the wrapper. My son took the plastic off, we took a look, then put it on my test track (DC equiped, MRC Throttlepak). Well the engine will not run??! The lights work (front in forward, and the tender light in reverse), but it want move a muscel. What gives? I though all DCC engines would work on DC also??
Was told by my LHS guy, that it could have a hard-wired decoder in it? Is that what is wrong? If this thing is bad, how do I tell, before voiding the warranty taking a decoder out?
Please someone help :(
Thanks, Kevin
 

·
Yard Master & Research
Joined
·
10,753 Posts
It seems like a similiar problem with Lionel Railsounds. I suspect with DCC the engine needs to be addressed. If it has a decoder an address is programmed. In normal DC ops it may need some bell/ whistle commands. I suggest going to the Spectrum site and reading up.I have found the brand names have good sites with plenty of reference material.
Some members do have Spectrums so maybe they can give more info. This is my limit on the knowledge part.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #4
Thanks guys. I sent a message to the ebay store I bought it from, and he said, that it should work with DC with no problems. I have a N&W J #608 that I want to send in to have upgraded, I may just send this one in too and have them make sure it will run on DC.
Kevin
 

·
Registered
Joined
·
241 Posts
Discussion Starter #6
I ment to repost again before I left for vacation Sat before-last.
I decided to try it once more, before returning it to Bachmann for a replacement. As before, the lights worked, but no movement. So, I got a little flustraited and began tapping on the boiler. Well, after about a halfdozen taps, it began to move. I ran it back and forth for about 15mins, without fail.!? I guess it was just stuck or something? Go figure, I guess it was just my luck, or badluck for that matter, lol.
Kevin
 
1 - 7 of 7 Posts
Top