Model Train Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter #1
wahoo my new to me locos arrived in the mail box today. im pretty stoked about these. Im looking forward to putting them on the track and running them with lots of cars behind them. cant hardly wait both Kato units and dcc already installed ya baby sid happy camper today:D:D:D:D:smilie_daumenpos: the jewel cases are from different locos
 

Attachments

·
Registered
Joined
·
199 Posts
Very nice! I think you'll be happy with them, they're very quiet and run flawlessly.

I have the same set but without dcc. The first pair were purchased about 20 years ago with 2 of the 4 car sets that made up the Super Chief, and about a month ago I added another pair from the reissue and the third 4 car set.
Those 4 engines will pull every car in the sets plus all of the freight cars I can fit without breaking a sweat!
 

·
Registered
Joined
·
230 Posts
I own several Kato F7 and F3s from the first run, they don't run very well. Hope yours run a lot better.
 

·
Registered
Joined
·
647 Posts
Discussion Starter #9
Thank you guys. i have not run them yet. bought them from ebayer who had a pretty good sized layout. he is selling everything. i probably should test run them hahahaha. maybe today ill set up an oval track and play with them. cant hardly wait. always exciting when you get new toys.
 

·
Registered
Joined
·
381 Posts
Purty.

I own several Kato F7 and F3s from the first run, they don't run very well. Hope yours run a lot better.
That's the first time I've heard of KATO's that don't run, well, like a KATO! You should contact the company as they have a reputation for smooth running engines and a reputation to keep up.
 

·
Registered
Joined
·
647 Posts
Discussion Starter #13
well i felt better today so i set up a temp oval track to test the new to me locos. they run pretty good and pretty quite. but im gunna need to adjust the speed. the b unit flat outruns the f unit hahahahaha hope this works



 
1 - 14 of 14 Posts
Top